blog/flake.nix
James Walker df332d5b2b
All checks were successful
continuous-integration/drone/push Build is passing
💥 giving lume / deno a try
2024-05-23 15:37:43 -04:00

27 lines
567 B
Nix

{
description = "walkah's blog";
inputs = {
nixpkgs.url = "github:nixos/nixpkgs/nixpkgs-unstable";
flake-utils.url = "github:numtide/flake-utils";
flake-compat = {
url = "github:edolstra/flake-compat";
flake = false;
};
};
outputs = { nixpkgs, flake-utils, ... }:
flake-utils.lib.eachDefaultSystem (system:
let
pkgs = nixpkgs.legacyPackages.${system};
in
{
devShells.default = pkgs.mkShell {
name = "blog";
buildInputs = with pkgs; [ deno ];
};
}
);
}