dotfiles/home.nix
2023-10-13 21:27:42 -04:00

30 lines
810 B
Nix

{ pkgs, ... }: {
# Let Home Manager install and manage itself.
programs.home-manager.enable = true;
# Home Manager needs a bit of information about you and the
# paths it should manage.
home = {
username = "walkah";
homeDirectory = if pkgs.stdenv.isDarwin then "/Users/walkah" else "/home/walkah";
};
imports = [
./modules
];
programs = {
vim = { enable = true; };
};
# This value determines the Home Manager release that your
# configuration is compatible with. This helps avoid breakage
# when a new Home Manager release introduces backwards
# incompatible changes.
#
# You can update Home Manager without changing this value. See
# the Home Manager release notes for a list of state version
# changes in each release.
home.stateVersion = "23.05";
}